MikroTik PPPoE Setup

Same interface: Hotspot & PPPoE

/interface bridge
add name=bridge-hotspot-pppoe
/ip pool
add name=pppoe-pool ranges=192.168.12.2-192.168.12.254
add name=pppoe-expired ranges=10.0.0.2-10.0.0.254
/ppp aaa
set use-radius=yes
/ip firewall filter
add action=accept chain=forward dst-port=53 protocol=tcp src-address-list=\
    EXPIRED
add action=accept chain=forward dst-port=53 protocol=udp src-address-list=\
    EXPIRED
add action=drop chain=forward src-address-list=EXPIRED
/ip firewall address-list
add address=10.0.0.0/24 list=EXPIRED
/interface pppoe-server server
add disabled=no interface=bridge-hotspot-pppoe keepalive-timeout=15 \
    one-session-per-host=yes service-name=pppoe-server
/ip address
add address=192.168.12.1/24 comment=PPPoE interface=bridge-hotspot-pppoe \
    network=192.168.12.0
/ppp profile
add change-tcp-mss=yes dns-server=8.8.8.8,8.8.4.4 local-address=192.168.12.1 \
    name="Plan 500 30 Days" only-one=yes rate-limit=2M/2M remote-address=\
    pppoe-pool
add change-tcp-mss=yes dns-server=8.8.8.8,8.8.4.4 local-address=192.168.12.1 \
    name="Plan 1000 30 Days" only-one=yes rate-limit=5M/5M remote-address=\
    pppoe-pool
add change-tcp-mss=yes dns-server=8.8.8.8,8.8.4.4 local-address=192.168.12.1 \
    name="Plan 1500 30 Days" only-one=yes rate-limit=8M/8M remote-address=\
    pppoe-pool
add change-tcp-mss=yes local-address=10.0.0.1 name=EXPIRED only-one=yes \
    rate-limit=1k/1k remote-address=pppoe-expired-pool
/ppp secret
add name=user@500 password=StrongPassWord profile="Plan 500 30 Days" service=pppoe
add name=user@1000 password=StrongPassWord profile="Plan 1000 30 Days" service=pppoe
add name=user@1500 password=StrongPassWord profile="Plan 1500 30 Days" service=pppoe

PPPoE Script: